Latency with ShareFile Services
Incident Report for ShareFile® System Status
Resolved
At this point, we believe the incident to be fully resolved.

If any further issues are seen, please contact Citrix Technical Support.
Posted 2 months ago. Mar 14, 2019 - 11:16 EDT
Investigating
We have received reports and are seeing issues with latency within the ShareFile service. This includes the Web Application as well as other ShareFile clients.

We are aware and investigating as a priority. We will provide an update as soon as new information is available.
Posted 2 months ago. Mar 14, 2019 - 09:43 EDT
This incident affected: ShareFile®.