Support toll-free number unavailable
Incident Report for ShareFile® Status Page
Resolved
The US toll-free number to reach ShareFile Customer Support (800-441-3453) is now available. Thank you for your patience as we worked with the necessary parties to resolve this issue.
Posted Sep 18, 2015 - 08:56 EDT
Identified
Our toll-free telecom provider has reported a major service disruption in their infrastructure, and is continuing to work to resolve the cause of this event. Support is available at the toll number listed below, and we sincerely apologize for the inconvenience this has caused.
Posted Sep 17, 2015 - 22:07 EDT
Investigating
The US toll-free number to reach ShareFile Customer Support (800-441-3453) is currently unavailable due to a telecom issue. We are working with the service provider to restore service - in the meantime, ShareFile Support can be reached at 919-745-6111 in the interim.
Posted Sep 17, 2015 - 14:55 EDT