Intermittent Issues with ShareFile Plan Changes
Incident Report for ShareFile® System Status
Resolved
At this point, we have determined the issue is fully resolved and plan changes within ShareFile should be behaving normally.
Posted 21 days ago. Sep 28, 2018 - 14:09 EDT
Investigating
We are aware of intermittent issues affecting ShareFile plan changes and our platform team is currently diagnosing and taking remedial action.

We will update this page as additional information is available, and apologize for any inconvenience this may have caused.
Posted 21 days ago. Sep 28, 2018 - 12:59 EDT
This incident affected: ShareFile®.