Issues navigating to accounts using CitrixData.com
Incident Report for ShareFile® Status Page
Resolved
11:55am ET - At this time we believe that we have fully resolved the issues that were the root of problems with CitrixData.com account. There were unintended adjustments to our domain registration that impacted the accessibility of accounts using the domain. We believe all accounts should be able to access their login page at this time. If not, users are advised to fully clear cache and restart browser before trying again. Please then contact our support team with any further issues. We apologize for the inconvenience caused by these issues.
Posted Dec 10, 2014 - 11:58 EST
Investigating
9:27am ET - We have heard reports from clients who are experiencing errors when navigating to accounts that use CitrixData.com as their domain. An error message is thrown rather than the normal login page. We are currently working to research and resolve and will provide updates whenever possible.
Posted Dec 10, 2014 - 09:33 EST