ShareFile Phone System Temporarily Unavailable
Incident Report for ShareFile® System Status
Resolved
We have identified the issue that was causing the ShareFile phone system to be unavailable. We apologize for any inconveniences this may have caused.
Posted about 2 months ago. Nov 30, 2017 - 12:42 EST
Investigating
We are investigating an issue that is causing our phone system to be temporarily unavailable. This issue is being worked on as a high priority. We apologize for this inconvenience.
Posted about 2 months ago. Nov 30, 2017 - 11:24 EST