Latency with ShareFile Services
Incident Report for ShareFile® System Status
Resolved
At this point we are confident that response times have returned to normal and the issues seen with latency are now resolved.
Should any unusual behavior be seen, please contact Citrix Technical Support.
Posted about 2 months ago. Oct 25, 2018 - 14:48 EDT
Investigating
We have received reports and are seeing issues with latency in the Content Collaboration (ShareFile) service across applications within ShareFile.

We are aware and investigating as a priority. We will provide an update as soon as new information is available.
Posted about 2 months ago. Oct 25, 2018 - 11:42 EDT
This incident affected: ShareFile®.