Phone Support Unavailable
Incident Report for ShareFile® Status Page
Resolved
The emergency situation in the primary support office has been resolved. We apologize for the delay and are working to answer calls quickly as support personnel return to the phones.
Posted Feb 06, 2015 - 09:41 EST
Investigating
Phone support is temporarily unavailable while we experience issues with our office. We apologize for the inconvenience and support should return shortly.
Posted Feb 06, 2015 - 09:31 EST