ShareFile Phone Support
Incident Report for ShareFile® Status Page
Resolved
9/23/14 - 2:22pm ET - Issues should now be resolved with our ShareFile phone line. You can reach phone support normally at this time.
Posted Sep 23, 2014 - 14:23 EDT
Investigating
9/23/14 - 1:56pm ET - We are currently experiencing issues with our 1-800-441-3453 phone support number for ShareFile. We are diligently working to bring the number back online. We will provide updates as they are made available. You can still email at support@sharefile.com for support while we work to resolve these issues.
Posted Sep 23, 2014 - 13:58 EDT