Latency with ShareFile Services
Incident Report for ShareFile® Status Page
Resolved
At this point, we believe the incident to be fully resolved.

If any further issues are seen, please contact Citrix Technical Support.
Posted Nov 20, 2018 - 10:27 EST
Monitoring
At this point, we have implemented changes that we believe have resolved the latency that was previously seen across the ShareFile service.
We will continue to monitor performance in the near-term and will mark this issue resolved as soon as we have verified the fix.
Posted Nov 20, 2018 - 10:17 EST
Investigating
We have received reports and are seeing issues with latency within the ShareFile service. This includes the Web Application as well as other ShareFile clients.

We are aware and investigating as a priority. We will provide an update as soon as new information is available.
Posted Nov 20, 2018 - 10:11 EST
This incident affected: ShareFile®.