Inclement Weather / Support Availability
Incident Report for ShareFile® Status Page
Resolved
Conditions in the Raleigh, NC area have improved and the Citrix office is now open. Support availability has returned to normal and can be contacted through the typical methods.
Posted Feb 27, 2015 - 07:55 EST
Investigating
Due to a major winter storm in the Raleigh, NC area, the Citrix office has closed in the interest of our employee's safety.
ShareFile support is still available, however the time it takes to reach an agent may be longer than expected due to availability. We apologize for any inconvenience and will update as conditions change.
Posted Feb 26, 2015 - 06:38 EST