ShareFile Download/Upload Latency
Incident Report for ShareFile® Status Page
Resolved
At this point, we have determined that the issue is fully resolved and the ShareFile application should be behaving normally.
Posted Nov 15, 2018 - 18:00 EST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2018 - 17:33 EST
Investigating
We are aware of an issue causing latency and download/upload issues within ShareFile. Our operations and engineering teams are working on diagnosing the issue and taking remedial action.

We will update this page as additional information is available, and apologize for any inconvenience this may have caused.
Posted Nov 15, 2018 - 17:26 EST
This incident affected: ShareFile®.