Failures/latency with upload, download, and preview
Incident Report for ShareFile® System Status
Resolved
At this point in time, we believe the issues with latency and other services should be resolved. We will continue monitoring these services to ensure appropriate functionality.
Should any improper behavior be seen in ShareFile, please contact our dedicated support team.
Posted 3 months ago. Aug 31, 2017 - 16:06 EDT
Investigating
We are aware of an issue with upload, download, and/or previewing files which may prevent or delay the successful completion of these operations. Our operations and engineering teams are working on diagnosing the issue and taking remedial action.

We will update this page as additional information is available, and apologize for any inconvenience this may have caused.
Posted 3 months ago. Aug 31, 2017 - 15:04 EDT