Support toll-free number unavailable
Incident Report for ShareFile® System Status
Resolved
The US toll-free number to reach ShareFile Customer Support (800-441-3453) is now available. Thank you for your patience as we worked with the necessary parties to resolve this issue.
Posted about 2 months ago. May 02, 2017 - 03:36 EDT
Investigating
The US toll-free number to reach ShareFile Customer Support (800-441-3453) is currently unavailable due to a telecom issue. We are working with the service provider to restore service - in the meantime, ShareFile Support can be reached at support@sharefile.com in the interim.
Posted about 2 months ago. May 02, 2017 - 03:21 EDT