Phone Support Impacted
Incident Report for ShareFile® Status Page
Resolved
Support is now able to conduct interactions appropriately and phone support is back online. We apologize for any inconvenience caused.
Posted May 25, 2016 - 15:44 EDT
Investigating
Due to a facility issue at the ShareFile office, phone support is currently unavailable. We will bring support back online just as soon as possible and will provide updates here.
Posted May 25, 2016 - 15:22 EDT