Latency with ShareFile Service
Incident Report for ShareFile® System Status
Resolved
At this point, we are comfortable calling this issue fully resolved.

Please reach out to Citrix support for any further technical issues seen with the ShareFile application.
Posted 2 months ago. Oct 09, 2018 - 14:07 EDT
Identified
We have identified the issue and are working diligently to resolve. We will provide an update as soon as the appropriate update is released.
Posted 2 months ago. Oct 09, 2018 - 13:07 EDT
Investigating
We have received reports and are seeing issues with latency in the ShareFile service. This may impact our web application as well as desktop tools.

We are aware and investigating as a priority. We will provide an update as soon as new information is available.
Posted 2 months ago. Oct 09, 2018 - 12:00 EDT
This incident affected: ShareFile®.