Citrix ShareFile customers may be experiencing issues.
Incident Report for Citrix ShareFile® Status Page
Resolved
Current Status:
At this time, we believe that the issues affecting Citrix Content Collaboration have been fully resolved. We will continue to monitor closely.

Next Steps:
If any further issues are seen, please contact Citrix Technical Support.
Posted Mar 01, 2021 - 16:57 EST
Identified
Impact:
Citrix Content Collaboration service is currently experiencing issues that would impact a subset of customers in the US region. Impacted customers would have issues accessing or using Citrix ShareFile.

Current Status:
Citrix Engineering has identified the issue and working on mitigations.

Next Steps:
Another update will be provided within the next 60 minutes.
Posted Mar 01, 2021 - 16:42 EST
Investigating
Impact:
Citrix Content Collaboration service is currently experiencing issues that would impact a subset of customers in the US region. Impacted customers would have issues accessing or using Citrix ShareFile.

Current Status:
We are currently investigating the issue. Citrix Engineering team is actively working on mitigation.

Next Steps:
Another update will be provided within the next 60 minutes.
Posted Mar 01, 2021 - 15:48 EST
This incident affected: ShareFile®.