Phone Support Degraded
Incident Report for ShareFile® Status Page
Resolved
Our networking issues have been resolved and phone support quality is at full capacity.
Posted Jul 23, 2014 - 10:27 EDT
Investigating
Due to network issues at our corporate office, phone support quality is degraded. Our team is diligently working to resolve these issues and return call quality. We will provide updates when available.
Posted Jul 23, 2014 - 10:21 EDT