Citrix Files Latency
Incident Report for ShareFile® System Status
Resolved
At this time we believe the Citrix Files latency and authentication issues to be fully resolved based on the mitigation steps completed by our engineering teams. We continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Nov 11, 2019 - 12:54 EST
Investigating
We have received reports of latency on Citrix Files applications. Users may be experiencing latency and login issues
We are working to research and resolve the issue and will provide updates as soon as additional information is available.
Posted Nov 11, 2019 - 11:09 EST
This incident affected: ShareFile®.