Citrix Content Collaboration (ShareFile) customers experiencing authentication issues.
Incident Report for ShareFile® System Status
Resolved
At this time, we believe that the issue affecting user authentication for Citrix Content Collaboration (ShareFile), ShareFile applications, Medical Image Viewer, and RightSignature services (across all regions) has been fully resolved. We will continue to monitor closely.

If any further issues are seen, please contact Citrix Technical Support. Citrix will be undertaking a full RCA into the issue. Citrix would like to apologize for any inconvenience caused.
Posted Jul 24, 2020 - 17:32 EDT
Identified
Citrix Content Collaboration (ShareFile), ShareFile applications, Medical Image Viewer, and RightSignature services are currently experiencing login issues across all regions.

For some impacted customers, clearing cookies and cache on the respective browsers has resolved the issue.

We continue our investigation and evaluating mitigation steps. A further update will be provided at 21:45 UTC or sooner.
Posted Jul 24, 2020 - 16:53 EDT
Investigating
Citrix Content Collaboration (ShareFile) service is currently experiencing issues in the all regions. Some users are not able to access their Citrix Content Collaboration services (Authentication Issue).

We are currently investigating the issue. A further update will be provided at 21:15 UTC or sooner.
Posted Jul 24, 2020 - 16:18 EDT
This incident affected: ShareFile®.