Citrix Files Latency
Incident Report for ShareFile® System Status
Resolved
At this point, we believe we have made the appropriate adjustments to deem this issue resolved. We will continue to monitor for any additional issues.
Should further issues be seen, please contact Citrix Technical Support.
Posted May 22, 2019 - 13:13 EDT
Investigating
We have been made aware of issues ongoing for certain users of the Citrix Files application and tools. Users may be experiencing latency and loading issues with the web application and tools.

We are working to research and resolve the issue and will provide updates as soon as additional information is available.
Posted May 22, 2019 - 12:43 EDT
This incident affected: ShareFile®.