ShareFile Mobile App for Android v6.7 Application Crash
Incident Report for ShareFile® System Status
Resolved
Our development team has been able to identify and resolve the issue causing the Android application to crash. The new version of the application (version 6.7.1) with the fix has been published to the Android App Store and is now available.

We greatly appreciate your patience while we worked to resolve the issue and apologize for any inconvenience this may have caused.
Posted 7 months ago. Feb 22, 2018 - 13:48 EST
Investigating
This morning we began to receive reports of crashes occurring with latest build of the ShareFile mobile app for Android v6.7 on Android operating system v7.0. The ShareFile Mobile Development team is aware of the situation and is diligently working on a hotfix release to address this reported behavior. Updates will be provided as they become available.
Posted 7 months ago. Feb 22, 2018 - 08:59 EST