Citrix Files Latency
Incident Report for ShareFile® System Status
Resolved
At this point, we believe we have made the appropriate adjustments to deem this issue resolved. We will continue to monitor for any additional issues.
Should further issues be seen, please contact Citrix Technical Support.
Posted Apr 23, 2019 - 14:43 EDT
Investigating
We have received multiple reports that customers are experiencing latency issues within the Citrix Files Web Application. We're working to research and resolve the issue and will provide updates as soon as additional information is available.
Posted Apr 23, 2019 - 14:24 EDT
This incident affected: ShareFile®.