Citrix ShareFile U.S. Region customers reporting access issues.
Incident Report for ShareFile® System Status
Resolved
The issue impacting customers of Citrix ShareFile has been resolved. Citrix Engineering will continue to monitor closely. If any further issues are experienced, please contact Citrix Technical Support.
Posted Jan 17, 2020 - 11:23 EST
Investigating
Citrix ShareFile U.S. and EMEA customers are experiencing intermittent issues uploading encrypted E-mails (via Outlook or WebApp). Our Engineering team is engaged and investigating the issue.
Posted Jan 17, 2020 - 10:30 EST
This incident affected: ShareFile®.