ShareFile experiencing issues with file downloads

Incident Report for ShareFile® Status Page

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 14:03 EST

Update

System is fully operational.
Posted Feb 19, 2025 - 14:03 EST

Monitoring

A fix has been applied and the system is recovering. We'll continue to monitor to ensure complete recovery.
Posted Feb 19, 2025 - 13:58 EST

Update

We have identified the cause and are continuing to investigate a fix.
Posted Feb 19, 2025 - 13:48 EST

Update

We have identified the cause and are investigating a fix.
Posted Feb 19, 2025 - 13:12 EST

Update

We are continuing to investigate this issue.
Posted Feb 19, 2025 - 12:46 EST

Investigating

We are currently investigating this issue.
Posted Feb 19, 2025 - 12:26 EST
This incident affected: ShareFile®.