Citrix Content Collaboration(ShareFile) services is experiencing issues
Incident Report for Citrix ShareFile® Status Page
Resolved
Citrix Content Collaboration(Sharefile) service is no longer experiencing issues. The Citrix engineering team will continue to monitor the service.


This will be the last communication on this Incident. Please get in touch with Citrix Support Team in case the issue persists.
Posted Mar 22, 2022 - 07:24 EDT
Investigating
Citrix Content Collaboration(Sharefile) service is currently experiencing issues in all geos that would impact end-users & admins. End-users & admins impacted are unable to access the service.


Next Steps: A further update will be provided within 60 minutes (no later than 12:00PM UTC).
Posted Mar 22, 2022 - 07:13 EDT
This incident affected: ShareFile®.