Citrix Content Collaboration (ShareFile) EU customers experiencing issues
Incident Report for Citrix ShareFile® Status Page
Resolved
Current Status:
No issues have been observed and at this time, we believe that the issues affecting a subset of Citrix ShareFile EU customers have been resolved.

Next Steps:
If any further issues are seen, please contact Citrix Technical Support. We will continue to monitor closely.
Posted Mar 26, 2021 - 09:28 EDT
Monitoring
Current Status:
At this time, we believe that the issues affecting a subset of Citrix ShareFile EU customers have been resolved.

Next Steps:
If any further issues are seen, please contact Citrix Technical Support. We will continue to monitor closely.
Posted Mar 25, 2021 - 13:02 EDT
Update
Citrix teams continue to investigate the issue and are actively working towards resolution. This site will be updated as more information becomes available (or no later than 18:00 UTC).
Posted Mar 25, 2021 - 12:20 EDT
Update
Citrix teams continue to investigate the issue and are actively working towards resolution. This site will be updated as more information becomes available
Posted Mar 25, 2021 - 10:45 EDT
Update
Citrix teams continue to investigate the issue and are actively working towards resolution. This site will be updated as more information becomes available
Posted Mar 25, 2021 - 09:28 EDT
Update
Citrix teams continue to investigate the issue and are actively working towards resolution. This site will be updated as more information becomes available
Posted Mar 25, 2021 - 08:04 EDT
Investigating
Impact: Citrix Content Collaboration (ShareFile) service is currently experiencing issues in EU regions. Impacted customers are seeing a Google Safe Browsing security alert while accessing or using Citrix ShareFile WebApp Services via Google Chrome, Firefox or Safari browsers.

Current Status: We are currently investigating the issue. Citrix Engineering team is actively working on mitigation.

Workaround:
• Microsoft Edge and Internet Explorer are not affected by this issue.
• Citrix Files for Windows, and Citrix Files for Mac are not affected.
• Mobile Apps on iOS and Android are not affected

Next Steps: Another update will be provided within the next 60 minutes.
Posted Mar 25, 2021 - 06:40 EDT
This incident affected: ShareFile®.