Window desktop application is down
Incident Report for ShareFile® Status Page
Resolved
Issue has been mitigated and Windows desktop application is back to normal state.
Posted Jul 04, 2024 - 23:52 EDT
Identified
Cause Identified and team working on the fix to get the system up and running.
Posted Jul 04, 2024 - 23:31 EDT
Investigating
We are currently investigating this issue.
Posted Jul 04, 2024 - 22:40 EDT
This incident affected: ShareFile®.