Citrix ShareFile customers experiencing issues previewing files.
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues affecting Citrix Content Collaboration (ShareFile) service have been fully resolved. We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Oct 26, 2020 - 14:09 EDT
Monitoring
Citrix Engineering has applied mitigation steps and will continue to monitor closely until fully resolved. A new update will be provided in the next 30 minutes or sooner if available.
Posted Oct 26, 2020 - 14:00 EDT
Investigating
Citrix engineers have identified an issue impacting Citrix Content Collaboration end-users on all regions that would impact the end-users' ability to preview a file (no other functionality is being impacted at this moment). As a workaround, file could be downloaded and then previewed.

A new update will be provided in the next 30 minutes or sooner if available.
Posted Oct 26, 2020 - 13:36 EDT
This incident affected: ShareFile®.