Content Collaboration end-users may be experiencing issues
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues affecting Citrix Content Collaboration(ShareFile) service have been fully resolved. We will continue to monitor closely.
Posted Jan 19, 2022 - 14:28 EST
Investigating
Impact: Citrix Share file users may currently be experiencing issues creating share links in US region.

Current Status: Citrix Engineering have identified and fixed the issue, and are working on the system performance.

Next Steps: A further update will be provided within 60 minutes (no later than 8:00PM UTC).
Posted Jan 19, 2022 - 14:15 EST
This incident affected: ShareFile®.