Citrix Content Collaboration (ShareFile) is currently experiencing issues in the U.S. region.
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe the issue affecting Citrix Content Collaborations(Sharefile) services in the US region has been resolved. We will continue to monitor closely.

If you have any further issues, please contact Citrix Technical Support.
Posted Oct 13, 2021 - 15:35 EDT
Investigating
Citrix Content Collaboration (ShareFile) is currently experiencing issues in the U.S. region that may be impacting end-users. Customers may experience issues connecting to the service, unable to display their respective login page, and observed performance degradation.

Next Step: Citrix Engineering is currently investigating the issue and a new update will be provided within the next 60 minutes.
Posted Oct 13, 2021 - 15:11 EDT
This incident affected: ShareFile®.