ShareFile users experiencing issues with logging in
Incident Report for ShareFile® Status Page
Resolved
This incident has been resolved.
Posted Aug 22, 2024 - 14:08 EDT
Investigating
ShareFile customers may be experiencing issues accessing the login page. We are investigating this issue and we will provide updates here as soon as possible.
Posted Aug 22, 2024 - 13:58 EDT
This incident affected: ShareFile®.