Citrix ShareFile may be experiencing issues...
Incident Report for Citrix ShareFile® Status Page
Resolved
Citrix Engineering teams have fully resolved the latency issues affecting a small subset of end-users.

We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Jan 08, 2021 - 14:31 EST
Identified
Citrix ShareFile is currently experiencing latency issues that would impact a small subset of end users in the US region.

We have identified the issue and are currently working on implementing and rolling out a fix.

Another update will be provided after the fix has been implemented, within the next 30 minutes.
Posted Jan 08, 2021 - 13:54 EST
Investigating
Citrix ShareFile is currently experiencing latency issues that would impact a small subset of end users in the US region.

We are currently investigating the issue.

Another update will be provided within the next 60 minutes.
Posted Jan 08, 2021 - 13:00 EST
This incident affected: ShareFile®.