Some customers may experience issues logging in or using ShareFile

Incident Report for ShareFile® Status Page

Resolved

The issue has been resolved, and all systems are now fully operational.
Posted May 08, 2025 - 02:23 EDT

Monitoring

Login issue for some ShareFile customers is resolved now, We are monitoring the systems.
Posted May 07, 2025 - 22:30 EDT

Investigating

The team has identified the issue and is working on a resolution.
Posted May 07, 2025 - 21:23 EDT
This incident affected: ShareFile®.