Citrix Content Collaboration may be experiencing issues...
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues affecting Citrix Content Collaboration have been fully resolved. We will continue to monitor closely.

If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 23, 2021 - 16:07 EST
Monitoring
At this time, we believe that the issues affecting Citrix Content Collaboration have been mitigated. We will continue to monitor closely.

If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 23, 2021 - 15:52 EST
Investigating
Citrix Content Collaboration service is currently experiencing issues that would impact a subset of customers in the US region. Impacted customers would have issues accessing or using Citrix ShareFile.

We are currently investigating the issue. Citrix Engineering team is actively working on mitigation.

Another update will be provided within the next 60 minutes.
Posted Feb 23, 2021 - 15:46 EST
This incident affected: ShareFile®.