Users unable to upload
Incident Report for ShareFile® Status Page
Postmortem

ShareFile Service Event – September 10, 2024 

 

Summary of Impact  

On September 10, 2024, between 4:50 PM EST and 5:56 PM EST, ShareFile users may have experienced issues with uploading files to their ShareFile accounts.  

Root Cause 

At 5:21 PM EST on September 10, 2024, ShareFile engineering began investigating reports that users received errors when uploading files into their ShareFile account. The investigation indicated that deployment of a new microservice version at 4:45 PM EST had a misconfiguration when initially deployed, which led to upload failures on ShareFile-managed StorageZones.  

Mitigation 

At 5:53 PM EST on September 10, 2024, the ShareFile operations team initiated a rollback of the microservice deployment to a previous version, which was completed at 5:56 PM EST. The rollback mitigated the issue immediately, allowing uploads to ShareFile-managed StorageZones to begin working again.  

 

Next Steps 

ShareFile engineering teams will improve testing to identify potential issues in this area before the deployments. They will also improve observability to be alerted about any potential issues involving the microservice deployments sooner. We apologize for the interruption in service.

Posted Sep 27, 2024 - 12:59 EDT

Resolved
This incident has been resolved.
Posted Sep 10, 2024 - 18:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2024 - 18:01 EDT
Investigating
We are currently investigating this issue.
Posted Sep 10, 2024 - 17:45 EDT
This incident affected: ShareFile®.