Citrix ShareFile service experienced issues in the US region
Incident Report for Citrix ShareFile® Status Page
Resolved
Current Status:

At this time, we believe that the issues affecting the Citrix ShareFile service have been fully resolved. We will continue to monitor closely.



Next Steps:

If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 16, 2022 - 12:35 EST
Update
We continue to investigate this issue.
Posted Feb 16, 2022 - 11:46 EST
Investigating
Impact: Citrix ShareFile service is experiencing issues in the US region leading to admins and users experiencing latency.



Current Status: Citrix Engineering has mitigated the issue and is monitoring recovery of the service.



Next Steps: A further update will be provided within 60 minutes.
Posted Feb 16, 2022 - 11:41 EST
This incident affected: ShareFile®.