Citrix ShareFile customers experiencing authentication and latency issues
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues affecting Content Collaboration have been fully resolved. We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support. Citrix will be undertaking a full RCA into the issue. Citrix would like to apologise for any inconvenience caused.
Posted May 04, 2020 - 13:41 EDT
Update
Citrix teams continue to investigate the performance issue and is actively working towards resolution. Next update will be provided by 5:45 P.M. UTC or when we have further information whichever is sooner.
Posted May 04, 2020 - 12:44 EDT
Update
Citrix Content Collaboration is currently experiencing degraded performance. We are currently investigating this issue. A further update will be provided by 5:35 P.M. UTC or when we have further information whichever is sooner.
Posted May 04, 2020 - 12:42 EDT
Identified
Citrix Content Collaboration is currently experiencing intermittent degraded performance. Customers should now be authenticate & access the console but may experience high latency. We are currently investigating this issue. A further update will be provided by 4:35 P.M. UTC or when we have further information whichever is sooner.
Posted May 04, 2020 - 11:39 EDT
Investigating
Citrix Teams are investigating a latency issue impacting customers of Citrix ShareFile authentication in the US region.

Citrix engineering is diligently working on resolution, and will provide additional updates on this site once available.
Posted May 04, 2020 - 10:55 EDT
This incident affected: ShareFile®.