Some ShareFile users may be experiencing issues with uploads and downloads on their accounts

Incident Report for ShareFile® Status Page

Resolved

The issue was specific to a single customer.
Posted Mar 31, 2026 - 18:06 EDT

Investigating

ShareFile customers may be experiencing issues with uploads and downloads. We are investigating this issue and we will provide updates here as soon as available.
Posted Mar 31, 2026 - 15:47 EDT