ShareFile customers may experience delays of transactional emails, including Password Reset links, New User Welcome emails, and Upload/Download notification alerts

Incident Report for ShareFile® Status Page

Resolved

We've confirmed the fix and email delivery of transactional emails should be back to normal.
Posted Sep 09, 2026 - 15:54 EDT

Monitoring

We have identified the issue affecting email delivery and have implemented a fix. We are monitoring the issue.
Posted Sep 09, 2026 - 15:44 EDT

Investigating

We have identified an issue affecting email delivery across ShareFile services. Customers may experience delays or non-delivery of transactional emails, including Password Reset links, New User Welcome emails, and Upload/Download notification alerts.
Posted Sep 09, 2026 - 14:38 EDT
This incident affected: ShareFile®.