Some ShareFile customers may be experiencing issues with emails and notifications

Incident Report for ShareFile® Status Page

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 20:34 EDT

Investigating

Some ShareFile customers may be experiencing issues with emails and notifications. We are working on investigating the issue.
Posted Jul 10, 2025 - 19:54 EDT
This incident affected: ShareFile®.