Citrix Content Collaboration (ShareFile) services may be experiencing issues
Incident Report for Citrix ShareFile® Status Page
Resolved
The issue is now resolved. If you are still noticing issues please contact the Citrix Support Team.
Posted Nov 17, 2021 - 16:15 EST
Update
Citrix Engineering quickly identified and remediated the latency issue. The team will continue to monitor closely.

This is the last communication on the incident.
Posted Nov 17, 2021 - 16:10 EST
Investigating
Impact:
Citrix Sharefile is currently experiencing issues in the US regions that would impact end-users. Users might experience latency issues.

Current Status:
Citrix Engineering team is investigating the issue.

Next Steps:
A further update will be provided within 60 minutes (no later than 9:30 PM UTC).
Posted Nov 17, 2021 - 15:54 EST
This incident affected: ShareFile®.