ShareFile logins down temporarily
Incident Report for ShareFile® Status Page
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 11:09 EDT
Investigating
ShareFile users may have experienced issues logging in between 10:30 and 10:40. We have resolved the issue and are back to normal operations
Posted Nov 02, 2023 - 11:09 EDT
This incident affected: ShareFile®.