Performance degradation of ShareFile

Incident Report for ShareFile® Status Page

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 17:52 EDT

Update

The team is continuing to investigate ShareFile performance issues and increased error rates. Another update will be provided as soon as available.
Posted Jul 14, 2025 - 16:18 EDT

Update

Experiencing the issues with login, performance and increased error rates. We are continuing to investigate this issue.
Posted Jul 14, 2025 - 14:03 EDT

Investigating

We are investigating customer reports of an issue impacting performance of ShareFile causing slowness in the application and increased error rates. Also, some customers are experiencing issues with login. We will provide updates here as soon as possible.
Posted Jul 14, 2025 - 11:41 EDT
This incident affects: ShareFile®.