Citrix ShareFile U.S. Region customers reporting latency issues.
Incident Report for Citrix ShareFile® Status Page
Resolved
Current Status:
At this time, we believe the performance issues impacting a subset of Citrix ShareFile customers in the US region have been fully resolved. We will continue to monitor closely.

Next Steps:
If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 04, 2021 - 09:31 EST
Monitoring
Current Status:
At this time, we believe the performance issues affecting Citrix ShareFile have been mitigated. We will continue to monitor closely.

Next Steps:
If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 03, 2021 - 20:08 EST
Investigating
Impact:
A subset of Citrix ShareFile customers in the US region are experiencing performance issues when uploading/downloading files or navigating through the application.

Current Status:
The Citrix Engineering team is investigating the issue and no available workarounds are available at this time.

Next Steps:
Next update will be provide by 00:15 UTC or sooner.
Posted Feb 03, 2021 - 18:38 EST
This incident affected: ShareFile®.