Citrix ShareFile customers reporting access issues.
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time we believe the Citrix ShareFile issues to be fully resolved. We continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Jan 06, 2020 - 14:13 EST
Investigating
Citrix ShareFile customers may have experience some issues accessing ShareFile. At this time we believe the Citrix ShareFile issues to be fully resolved. We continue to investigate and monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Jan 06, 2020 - 14:04 EST
This incident affected: ShareFile®.