Content Collaboration (ShareFile) customers having issues viewing files (US Region)
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues affecting Citrix Content Collaboration (ShareFile) service have been fully resolved. We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support.
Posted Nov 03, 2020 - 17:14 EST
Investigating
Citrix engineers have identified an issue impacting Citrix Content Collaboration end-users in the U.S. region that would impact the end-users' ability to view files.

A new update will be provided in the next 30 minutes or sooner if available.
Posted Nov 03, 2020 - 17:10 EST
This incident affected: ShareFile®.