Citrix ShareFile Latency
Incident Report for Citrix ShareFile® Status Page
Resolved
Our Operations and Engineering teams have identified and resolved the intermittent latency issues experienced by some customers.

We apologize for any inconvenience this may have caused.
Posted Sep 13, 2019 - 13:18 EDT
Investigating
We have been made aware of issues ongoing for certain users of the Citrix Files application and tools. Users may be experiencing latency and loading issues with the web application and tools.

We are working to research and resolve the issue and will provide updates as soon as additional information is available.
Posted Sep 13, 2019 - 12:01 EDT
This incident affected: ShareFile®.