Some ShareFile customers may be experiencing issues with login

Incident Report for ShareFile® Status Page

Postmortem

Summary of Impact 

On November 19, 2025, between approximately 9:00 AM and 10:36 AM UTC, some ShareFile customers experienced issues logging in to the service. The incident resulted in a partial login outage, primarily affecting users in the EU region, with intermittent impact in other regions. 

Root Cause 

The incident was triggered by an unusually high volume of SMS-based MFA requests that overwhelmed the ShareFile login service. This surge in MFA traffic caused resource exhaustion in backend systems responsible for authentication, leading to login failures. Temporary configuration limits and capacity constraints contributed to the inability to process requests efficiently during the peak. 

Mitigation 

The operations and engineering teams responded by: 

  • Enforcing further restrictions and rate limits for SMS-based MFA to prevent excessive requests. 

  • Modifying backend system configurations to handle higher login volumes. 

Once these actions were completed, normal login functionality was restored. 

Next Steps 

To prevent recurrence, ShareFile will: 

  • Continue to refine and enforce limits on SMS-based MFA requests. 

  • Strengthen monitoring and detection of excessive MFA activity targeting authentication systems. 

We apologize for any inconvenience this incident may have caused. For ongoing updates and incident history, please visit the ShareFile Status Page.

Posted Dec 08, 2025 - 09:30 EST

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 10:04 EST

Investigating

We are currently investigating this issue.
Posted Nov 19, 2025 - 10:03 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 09:48 EST

Investigating

We are currently investigating this issue.
Posted Nov 19, 2025 - 09:47 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 09:46 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 19, 2025 - 09:30 EST

Update

We’re currently experiencing an issue where some users may see an error stating “Unable to get login information.”
Our team is working to resolve this as quickly as possible.

Please try again after some time.
Thank you for your patience!
Posted Nov 19, 2025 - 09:13 EST

Investigating

Some ShareFile customers may be experiencing issues with login into ShareFile. We are investigating this issue and we will provide updates here as soon as available.
Posted Nov 19, 2025 - 08:26 EST
This incident affected: ShareFile®.