Citrix Content Collaboration Service Users may be experiencing issues
Incident Report for Citrix ShareFile® Status Page
Resolved
The incident has been resolved. Please get in touch with Citrix Support if the issue persists.
Posted Mar 17, 2022 - 12:44 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2022 - 12:33 EDT
Investigating
Impact:

Citrix Content Collaboration Service is currently experiencing issues in the US region that would impact users. Users impacted are facing performance issues on WebApp



Current Status:

We are currently investigating the issue.



Next Steps:

Another update will be provided within the next 60 minutes (no later than 5:30 PM UTC).
Posted Mar 17, 2022 - 12:01 EDT
This incident affected: ShareFile®.