Citrix ShareFile may be experiencing issues...
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues affecting Citrix ShareFile service have been fully resolved.

Preliminary evidence points the root cause to be due to an outage affecting an upstream dependency cloud provider that affected Citrix ShareFIle service. We will provide more information on the root cause as soon as it is available.

We will continue to monitor closely. If any further issues are seen, please contact Citrix Technical Support. Citrix would like to apologize for any inconvenience caused.
Posted Nov 25, 2020 - 17:07 EST
Update
Citrix ShareFile is experiencing an issue that would impact customers ability to login using MFA. Email notification delivery is also being impacted.

The issue continues to impact Citrix ShareFile customers. Preliminary evidence points to an issue affecting a third-party upstream cloud provider dependency. Citrix

Citrix Engineering continues to investigate the issue.

Another update will be provided within the next 60 minutes.
Posted Nov 25, 2020 - 15:52 EST
Update
Citrix ShareFile is experiencing an issue that would impact customers ability to login using MFA. Email notification delivery is also being impacted.

The issue has been identified. Preliminary evidence points to an issue affecting a third-party upstream cloud provider dependency.

Citrix Engineering continues to investigate the issue.

Another update will be provided within the next 60 minutes.
Posted Nov 25, 2020 - 14:20 EST
Identified
Citrix ShareFile is experiencing an issue that would impact customers ability to login using MFA. Email notification delivery is also being impacted.

The issue has been identified. Preliminary evidence points to an issue affecting a third-party upstream cloud provider dependency. Citrix Engineering is currently working on a hot fix to mitigate the issue.

Another update will be provided within the next 60 minutes.
Posted Nov 25, 2020 - 12:27 EST
Investigating
Citrix ShareFile is currently experiencing issues that would impact email notification delivery.

We are currently investigating the issue.

Another update will be provided within the next 60 minutes.
Posted Nov 25, 2020 - 11:58 EST
This incident affected: ShareFile®.